using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[[:alnum:]+\/]{4})*(?:[[:alnum:]+\/]{2}[AEIMQUYcgkosw048]=|[[:alnum:]+\/][AQgw]==)?$";
string input = @"valid Base64 encoding
AA==
/w==
/wA=
//8=
//8A
////
invalid Base64 encoding
A0==
/x==
/wB=
//9=
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}