$re = '/^(?:[[:alnum:]+\/]{4})*(?:[[:alnum:]+\/]{2}[AEIMQUYcgkosw048]=|[[:alnum:]+\/][AQgw]==)?$/m';
$str = 'valid Base64 encoding
AA==
/w==
/wA=
//8=
//8A
////
invalid Base64 encoding
A0==
/x==
/wB=
//9=
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);