import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![^/\\[|=<>!+*-])([a-zA-Z][a-zA-Z\\d_.:-]*)\n"
+ "|\n"
+ "(?<=\\s(?!and|or|mod|div))([a-zA-Z][a-zA-Z\\d_.:-]*)";
final String string = "dfd[dfdf=dsds/@dds/sds+sdsds ]/dsds";
final String subst = "*[local-name()='\\1\\2']";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}