import Foundation
let pattern = #"""
(?<![^/\[|=<>!+*-])([a-zA-Z][a-zA-Z\d_.:-]*)
|
(?<=\s(?!and|or|mod|div))([a-zA-Z][a-zA-Z\d_.:-]*)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"dfd[dfdf=dsds/@dds/sds+sdsds ]/dsds"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*[local-name()='\1\2']"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)