$re = '/(?<![^/\[|=<>!+*-])([a-zA-Z][a-zA-Z\d_.:-]*)
|
(?<=\s(?!and|or|mod|div))([a-zA-Z][a-zA-Z\d_.:-]*)/x';
$str = 'dfd[dfdf=dsds/@dds/sds+sdsds ]/dsds';
$subst = "*[local-name()='\1\2']";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;