re = /(?<![^\/\[|=<>!+*-])([a-zA-Z][a-zA-Z\d_.:-]*)
|
(?<=\s(?!and|or|mod|div))([a-zA-Z][a-zA-Z\d_.:-]*)/x
str = 'dfd[dfdf=dsds/@dds/sds+sdsds ]/dsds'
subst = '*[local-name()=\'\\1\\2\']'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result