use strict;
my $str = 'dfd[dfdf=dsds/@dds/sds+sdsds ]/dsds';
my $regex = qr/(?<![^/\[|=<>!+*-])([a-zA-Z][a-zA-Z\d_.:-]*)
|
(?<=\s(?!and|or|mod|div))([a-zA-Z][a-zA-Z\d_.:-]*)/xp;
my $subst = '*[local-name()=\'\\1\\2\']';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";