# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!^)|\bhref="(?=[^"]*\.(?:html?|php)"))[^"<_]*\K_/-/gm;t' <<< "href=\"http://some.site.com/path_here_and_here/site.html\"
href=\"http://some.site.com/path_here_and_here/site.htm\"
href=\"http://some.site.com/path_here_and_here/site.php\"
href=\"http://some.site.com/path_here_and_here/site.exe\"
href=\"http://some.site.com/path_here_and_here/site.zip\"
href=\"http://some.site.com/path_here_and_here/site.sit\"
href=\"http://some.site.com/path_here_and_here/site.dmg\""