re = /(?:\G(?!^)|\bhref="(?=[^"]*\.(?:html?|php)"))[^"<_]*\K_/m
str = 'href="http://some.site.com/path_here_and_here/site.html"
href="http://some.site.com/path_here_and_here/site.htm"
href="http://some.site.com/path_here_and_here/site.php"
href="http://some.site.com/path_here_and_here/site.exe"
href="http://some.site.com/path_here_and_here/site.zip"
href="http://some.site.com/path_here_and_here/site.sit"
href="http://some.site.com/path_here_and_here/site.dmg"'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result