import Foundation
let pattern = #"(?:\G(?!^)|\bhref="(?=[^"]*\.(?:html?|php)"))[^"<_]*\K_"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
href="http://some.site.com/path_here_and_here/site.html"
href="http://some.site.com/path_here_and_here/site.htm"
href="http://some.site.com/path_here_and_here/site.php"
href="http://some.site.com/path_here_and_here/site.exe"
href="http://some.site.com/path_here_and_here/site.zip"
href="http://some.site.com/path_here_and_here/site.sit"
href="http://some.site.com/path_here_and_here/site.dmg"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)