$re = '/(?:\G(?!^)|\bhref="(?=[^"]*\.(?:html?|php)"))[^"<_]*\K_/m';
$str = 'href="http://some.site.com/path_here_and_here/site.html"
href="http://some.site.com/path_here_and_here/site.htm"
href="http://some.site.com/path_here_and_here/site.php"
href="http://some.site.com/path_here_and_here/site.exe"
href="http://some.site.com/path_here_and_here/site.zip"
href="http://some.site.com/path_here_and_here/site.sit"
href="http://some.site.com/path_here_and_here/site.dmg"';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;