package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)#([^\s]+[^a-zA-Z-ÇŞĞÜÖİçşğüöı]+?)`)
var str = `$content = '#ahmet asfasf #ali ^+%^+%^+%';
$content = '#Barış asfasf #wmaraci asdasdads%&+%+/%(&(+^%^%+'!^%^+%'^+';
preg_match_all($pattern, $content, $results);
print_r($results[0]);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}