re = /(?i)#([^\s]+[^a-zA-Z-ÇŞĞÜÖİçşğüöı]+?)/
str = '$content = \'#ahmet asfasf #ali ^+%^+%^+%\';
$content = \'#Barış asfasf #wmaraci asdasdads%&+%+/%(&(+^%^%+\'!^%^+%\'^+\';
preg_match_all($pattern, $content, $results);
print_r($results[0]);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end