use strict;
my $str = '$content = \'#ahmet asfasf #ali ^+%^+%^+%\';
$content = \'#Barış asfasf #wmaraci asdasdads%&+%+/%(&(+^%^%+\'!^%^+%\'^+\';
preg_match_all($pattern, $content, $results);
print_r($results[0]);';
my $regex = qr/(?i)#([^\s]+[^a-zA-Z-ÇŞĞÜÖİçşğüöı]+?)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}