import Foundation
let pattern = ##"(?i)#([^\s]+[^a-zA-Z-ÇŞĞÜÖİçşğüöı]+?)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
$content = '#ahmet asfasf #ali ^+%^+%^+%';
$content = '#Barış asfasf #wmaraci asdasdads%&+%+/%(&(+^%^%+'!^%^+%'^+';
preg_match_all($pattern, $content, $results);
print_r($results[0]);
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)