// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)#([^\s]+[^a-zA-Z-ÇŞĞÜÖİçşğüöı]+?)").unwrap();
let string = "$content = '#ahmet asfasf #ali ^+%^+%^+%';
$content = '#Barış asfasf #wmaraci asdasdads%&+%+/%(&(+^%^%+'!^%^+%'^+';
preg_match_all($pattern, $content, $results);
print_r($results[0]);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}