$re = '/(?i)#([^\s]+[^a-zA-Z-ÇŞĞÜÖİçşğüöı]+?)/';
$str = '$content = \'#ahmet asfasf #ali ^+%^+%^+%\';
$content = \'#Barış asfasf #wmaraci asdasdads%&+%+/%(&(+^%^%+\'!^%^+%\'^+\';
preg_match_all($pattern, $content, $results);
print_r($results[0]);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);