using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^slug$|^slug-+[0-9]$";
string input = @"slug
slug-0
slug-5
slug-9
slug-10000
slug-abc
slugabc
slug0
slug10
1slugasv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}