$re = '/^slug$|^slug-+[0-9]$/m';
$str = 'slug
slug-0
slug-5
slug-9
slug-10000
slug-abc
slugabc
slug0
slug10
1slugasv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);