// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^slug$|^slug-+[0-9]$").unwrap();
let string = "slug
slug-0
slug-5
slug-9
slug-10000
slug-abc
slugabc
slug0
slug10
1slugasv";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}