import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^slug$|^slug-+[0-9]$";
final String string = "slug\n"
+ "slug-0\n"
+ "slug-5\n"
+ "slug-9\n"
+ "slug-10000\n"
+ "slug-abc\n"
+ "slugabc\n"
+ "slug0\n"
+ "slug10\n"
+ "1slugasv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}