const regex = /^slug$|^slug-+[0-9]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^slug$|^slug-+[0-9]$', 'gm')
const str = `slug
slug-0
slug-5
slug-9
slug-10000
slug-abc
slugabc
slug0
slug10
1slugasv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}