re = /^slug$|^slug-+[0-9]$/m
str = 'slug
slug-0
slug-5
slug-9
slug-10000
slug-abc
slugabc
slug0
slug10
1slugasv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end