import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(int|string|float|void)\\s[A-Za-z]+[(](([)]|(int|string|float)\\s[A-Za-z]+|[,]\\s(int|string|float)\\s[A-Za-z]+)*[)])";
final String string = "int hola()\n"
+ "int hola(int abcd)\n"
+ "int hola(int abcd, int j)\n"
+ "int hola(int abcd, int j, int j)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}