import Foundation
let pattern = #"(int|string|float|void)\s[A-Za-z]+[(](([)]|(int|string|float)\s[A-Za-z]+|[,]\s(int|string|float)\s[A-Za-z]+)*[)])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
int hola()
int hola(int abcd)
int hola(int abcd, int j)
int hola(int abcd, int j, int j)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)