const regex = /(int|string|float|void)\s[A-Za-z]+[(](([)]|(int|string|float)\s[A-Za-z]+|[,]\s(int|string|float)\s[A-Za-z]+)*[)])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(int|string|float|void)\\s[A-Za-z]+[(](([)]|(int|string|float)\\s[A-Za-z]+|[,]\\s(int|string|float)\\s[A-Za-z]+)*[)])', 'gm')
const str = `int hola()
int hola(int abcd)
int hola(int abcd, int j)
int hola(int abcd, int j, int j)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}