#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\S{1,})( = )(\S{1,})(;)"
Local $sString = " public void ApplyTo(TaskDialog dialog)" & @CRLF & _
" {" & @CRLF & _
" min = dialog.ProgressBarMinimum;" & @CRLF & _
" max = dialog.ProgressBarMaximum;" & @CRLF & _
" value = dialog.ProgressBarValue;" & @CRLF & _
" speed = dialog.ProgressBarMarqueeAnimationSpeed;" & @CRLF & _
" state = dialog.ProgressBarState;" & @CRLF & _
" style = dialog.ProgressBarStyle;" & @CRLF & _
" }"
Local $sSubst = "$3$2$1$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)