use strict;
my $str = ' public void ApplyTo(TaskDialog dialog)
{
min = dialog.ProgressBarMinimum;
max = dialog.ProgressBarMaximum;
value = dialog.ProgressBarValue;
speed = dialog.ProgressBarMarqueeAnimationSpeed;
state = dialog.ProgressBarState;
style = dialog.ProgressBarStyle;
}';
my $regex = qr/(\S{1,})( = )(\S{1,})(;)/mp;
my $subst = '$3$2$1$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";