$re = '/(\S{1,})( = )(\S{1,})(;)/m';
$str = ' public void ApplyTo(TaskDialog dialog)
{
min = dialog.ProgressBarMinimum;
max = dialog.ProgressBarMaximum;
value = dialog.ProgressBarValue;
speed = dialog.ProgressBarMarqueeAnimationSpeed;
state = dialog.ProgressBarState;
style = dialog.ProgressBarStyle;
}';
$subst = "$3$2$1$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;