import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S{1,})( = )(\\S{1,})(;)";
final String string = " public void ApplyTo(TaskDialog dialog)\n"
+ " {\n"
+ " min = dialog.ProgressBarMinimum;\n"
+ " max = dialog.ProgressBarMaximum;\n"
+ " value = dialog.ProgressBarValue;\n"
+ " speed = dialog.ProgressBarMarqueeAnimationSpeed;\n"
+ " state = dialog.ProgressBarState;\n"
+ " style = dialog.ProgressBarStyle;\n"
+ " }";
final String subst = "$3$2$1$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}