import re
regex = re.compile(r"(\S{1,})( = )(\S{1,})(;)", flags=re.MULTILINE)
test_str = (" public void ApplyTo(TaskDialog dialog)\n"
" {\n"
" min = dialog.ProgressBarMinimum;\n"
" max = dialog.ProgressBarMaximum;\n"
" value = dialog.ProgressBarValue;\n"
" speed = dialog.ProgressBarMarqueeAnimationSpeed;\n"
" state = dialog.ProgressBarState;\n"
" style = dialog.ProgressBarStyle;\n"
" }")
subst = "$3$2$1$4"
result = regex.sub(subst, test_str)
if result:
print(result)