import Foundation
let pattern = #"(\S{1,})( = )(\S{1,})(;)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
public void ApplyTo(TaskDialog dialog)
{
min = dialog.ProgressBarMinimum;
max = dialog.ProgressBarMaximum;
value = dialog.ProgressBarValue;
speed = dialog.ProgressBarMarqueeAnimationSpeed;
state = dialog.ProgressBarState;
style = dialog.ProgressBarStyle;
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3$2$1$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)