#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iu)(?=\S([^a-zа-яё0-9\s])(?=\S|$))"
Local $sString = "fdlfkjrj745*&^$*(fff fds09 4*wj9 j9jttgsg95349[s-0)(*(%_#" & @CRLF & _
"" & @CRLF & _
"apple,Iphone wesgfesrg ,123" & @CRLF & _
"" & @CRLF & _
"ЭЭЭ,ЭЭЭ валиден" & @CRLF & _
"ЭЭЭ ,ЭЭЭ не валиден" & @CRLF & _
"ЭЭЭ, ЭЭЭ не валиден" & @CRLF & _
"ЭЭЭ , ЭЭЭ не валиден"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")