import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\S([^a-zа-яё0-9\\s])(?=\\S|$))";
final String string = "fdlfkjrj745*&^$*(fff fds09 4*wj9 j9jttgsg95349[s-0)(*(%_#\n\n"
+ "apple,Iphone wesgfesrg ,123\n\n"
+ "ЭЭЭ,ЭЭЭ валиден\n"
+ "ЭЭЭ ,ЭЭЭ не валиден\n"
+ "ЭЭЭ, ЭЭЭ не валиден\n"
+ "ЭЭЭ , ЭЭЭ не валиден";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}