const regex = /(?=\S([^a-zа-яё0-9\s])(?=\S|$))/iug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\S([^a-zа-яё0-9\\s])(?=\\S|$))', 'iug')
const str = `fdlfkjrj745*&^\$*(fff fds09 4*wj9 j9jttgsg95349[s-0)(*(%_#
apple,Iphone wesgfesrg ,123
ЭЭЭ,ЭЭЭ валиден
ЭЭЭ ,ЭЭЭ не валиден
ЭЭЭ, ЭЭЭ не валиден
ЭЭЭ , ЭЭЭ не валиден`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}