use strict;
my $str = 'fdlfkjrj745*&^$*(fff fds09 4*wj9 j9jttgsg95349[s-0)(*(%_#
apple,Iphone wesgfesrg ,123
ЭЭЭ,ЭЭЭ валиден
ЭЭЭ ,ЭЭЭ не валиден
ЭЭЭ, ЭЭЭ не валиден
ЭЭЭ , ЭЭЭ не валиден';
my $regex = qr/(?=\S([^a-zа-яё0-9\s])(?=\S|$))/iup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}