re = /(?=\S([^a-zа-яё0-9\s])(?=\S|$))/i
str = 'fdlfkjrj745*&^$*(fff fds09 4*wj9 j9jttgsg95349[s-0)(*(%_#
apple,Iphone wesgfesrg ,123
ЭЭЭ,ЭЭЭ валиден
ЭЭЭ ,ЭЭЭ не валиден
ЭЭЭ, ЭЭЭ не вал иден
ЭЭЭ , ЭЭЭ не валиден'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end