#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Ulcerative colitis patient, biopsy taken from the(\s?\w*\s?)colon,(\s?\w*\s?)macroscopic inflammation vissible"
Local $sString = "Ulcerative colitis patient, biopsy taken from the descending colon, macroscopic inflammation vissible" & @CRLF & _
"Ulcerative colitis patient, biopsy taken from the descending colon, no macroscopic inflammation vissible" & @CRLF & _
"Ulcerative colitis patient, biopsy taken from the colon, macroscopic inflammation vissible" & @CRLF & _
"Ulcerative colitis patient, biopsy taken from the colon, no macroscopic inflammation vissible"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")