import re
regex = re.compile(r"Ulcerative colitis patient, biopsy taken from the(\s?\w*\s?)colon,(\s?\w*\s?)macroscopic inflammation vissible")
test_str = ("Ulcerative colitis patient, biopsy taken from the descending colon, macroscopic inflammation vissible\n"
"Ulcerative colitis patient, biopsy taken from the descending colon, no macroscopic inflammation vissible\n"
"Ulcerative colitis patient, biopsy taken from the colon, macroscopic inflammation vissible\n"
"Ulcerative colitis patient, biopsy taken from the colon, no macroscopic inflammation vissible")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")