re = /Ulcerative colitis patient, biopsy taken from the(\s?\w*\s?)colon,(\s?\w*\s?)macroscopic inflammation vissible/
str = 'Ulcerative colitis patient, biopsy taken from the descending colon, macroscopic inflammation vissible
Ulcerative colitis patient, biopsy taken from the descending colon, no macroscopic inflammation vissible
Ulcerative colitis patient, biopsy taken from the colon, macroscopic inflammation vissible
Ulcerative colitis patient, biopsy taken from the colon, no macroscopic inflammation vissible'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end