import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Ulcerative colitis patient, biopsy taken from the(\\s?\\w*\\s?)colon,(\\s?\\w*\\s?)macroscopic inflammation vissible";
final String string = "Ulcerative colitis patient, biopsy taken from the descending colon, macroscopic inflammation vissible\n"
+ "Ulcerative colitis patient, biopsy taken from the descending colon, no macroscopic inflammation vissible\n"
+ "Ulcerative colitis patient, biopsy taken from the colon, macroscopic inflammation vissible\n"
+ "Ulcerative colitis patient, biopsy taken from the colon, no macroscopic inflammation vissible";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}