import Foundation
let pattern = #"Ulcerative colitis patient, biopsy taken from the(\s?\w*\s?)colon,(\s?\w*\s?)macroscopic inflammation vissible"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Ulcerative colitis patient, biopsy taken from the descending colon, macroscopic inflammation vissible
Ulcerative colitis patient, biopsy taken from the descending colon, no macroscopic inflammation vissible
Ulcerative colitis patient, biopsy taken from the colon, macroscopic inflammation vissible
Ulcerative colitis patient, biopsy taken from the colon, no macroscopic inflammation vissible
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)