using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w*ViewModel|(\w{2,}Model)\b";
string input = @"MyModel // - do match
MyViewModel // - do not match
This is a Model and this is another model
This is MyModelTrain testModel";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}