use strict;
my $str = 'MyModel // - do match
MyViewModel // - do not match
This is a Model and this is another model
This is MyModelTrain testModel';
my $regex = qr/\w*ViewModel|(\w{2,}Model)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}