const regex = /\w*ViewModel|(\w{2,}Model)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w*ViewModel|(\\w{2,}Model)\\b', 'gm')
const str = `MyModel // - do match
MyViewModel // - do not match
This is a Model and this is another model
This is MyModelTrain testModel`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}