// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w*ViewModel|(\w{2,}Model)\b").unwrap();
let string = "MyModel // - do match
MyViewModel // - do not match
This is a Model and this is another model
This is MyModelTrain testModel";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}