import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w*ViewModel|(\\w{2,}Model)\\b";
final String string = "MyModel // - do match\n"
+ "MyViewModel // - do not match\n"
+ "This is a Model and this is another model\n"
+ "This is MyModelTrain testModel";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}