# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<t(d|r)>/\n<t\1>/gu;t' <<< "<table><tr><td>Cell text</td></tr><tr>"