$re = '/<t(d|r)>/u';
$str = '<table><tr><td>Cell text</td></tr><tr>';
$subst = "\n<t\1>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;