const regex = /<t(d|r)>/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<t(d|r)>', 'gu')
const str = `<table><tr><td>Cell text</td></tr><tr>`;
const subst = `\n<t\1>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);